Windows Server 2012 Hyper-v NIC Team + Cisco Port-channel 設定(LCAP)

現在新的主機基本上會有2個port 以上的網卡,以我目前公司R610為例,採購來就有4port網路,該台規劃為Hyper-v 主機。

因為公司有多個網段,Hyper-v Host 上的VM有可能隸屬不同IP網段,如果Hyper-v Host

設定了4個外部虛擬交換器,這樣每個虛擬交換器對應各個網段使用上彈性不大,如果某一

張網路介面出了問題連接此虛擬交換器的VM網路就會發生問題。

若以我的主機為例會將使用其中一個port當作系統管理用設定IP,一個por live migration

用,其他兩個Port會利用ws2012 NIC Team 功能搭配ciso Port-channel 來增網路頻寬及網

路卡容錯,並且設定為trunk port 可以乘載多個VLAN使用彈性比較大。

先來了解cisoc 設定,目前R610是接在一台cisco 2970 L2 的switch

Cisco EtherChannel主要有兩種協定可選擇,分別為PAgP(Port Aggregation Protocol)與LACP(Link Aggregation Control Protocol)。

–PAgP是Cisco私有的協定,只能被用在Cisco自家的交換器之間。

mode:
Auto :          這種模式會使端口進入被動協商,對PagP數據包有反應但不會發起主動協商
Desirable :  這種模式會使端口進入主動協商。接口會透過發送PAgP來與其他接口進行協商
On:              不使用PAgP來形成Enterchannel
Non-silent:  如果交換機連接到有PAgP能力的設備,可以將接口配置為non silent。non silent為auto或desirable模式指定non-silent關鍵字,如果沒指定就會假設狀態為silent。而silent

沉默設置被用於連接到文件服務器或包分析儀。該設置允許PAgP,將接口添加至Channel組,並使用接口進行傳輸

–LACP則是由IEEE開放協定的標準(802.3ad),它可以用在不同廠牌之間的交換器,前提是需支援上述協定

mode:
Passive:會進入被動協商狀態,端口會對LACP數據包做出回應,但端口不會主動發起協商
Active:會進入主動協商狀態,端口會通過發送LCAP數據包來主動與其他接口進行協商
On: 強制形成EtherChannel ,並且不需要使用PAgP或LACP進行協商

資料來源 : http://ladfi.blogspot.tw/2012/02/cisco-port-channel.html

設定:

指令如下:

config 模式 建立port-channel 因為該port-channel 我是讓跑trunk mode 所以才這樣設定

依照需求也是可以設定access mode ,指令如下

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk

1

再來就是兩個port 加入該群組

interface GigabitEthernet0/17
switchport trunk encapsulation dot1q
channel-group 1 mode passive

interface GigabitEthernet0/18
switchport trunk encapsulation dot1q
 channel-group 1 mode passive

 

Switch 設定完畢後接著就開始設定Windows Server NIC Team(網卡小組)

NIC Team 兩組基本的演算法

1. [需要交換器才能參與小組的演算法,也就是所謂的「交換器相依模式」]

2.[不需要交換器就能參與小組的演算法,也就是所謂的「交換器獨立模式

模式有三種

1.交換器獨立: 小組網路介面卡可以連接至不同的交換器

2.靜態小組(IEEE 802.3ad draft v1) :

屬於交換器相依模式(ependent teaming)網路卡必須連接同一台交換器。

這個模式需要交換器和電腦上的設定,以識別哪些連結形成小組。因為這是以靜態方式設定的解決方案,因此沒有其他通訊協定可協助交換器和電腦識別錯誤地插入的纜線,或可能造成小組失敗的其他錯誤。伺服器等級的交換器通常會支援這個模式。

3.LCAP(IEEE 802.1ax, LACP)):

IEEE 802.1ax 使用連結彙總控制通訊協定 (Link Aggregation Control Protocol,LACP),以動態方式識別電腦與特定交換器之間的連結。這樣可以自動建立小組,而且理論上,只要從對等網路介面卡傳輸或接收 LACP,就可以擴充或縮減小組。一般伺服器等級的交換器支援 IEEE 802.1ax,但大部分的交換器需要手動管理,才能在連接埠上啟用 LACP。

3    4

Load balancing mode(負載平衡模式):

有兩種

1. Address Hash (位址雜湊) :

這個演算法會根據封包的元件建立雜湊,然後將擁有該雜湊值的封包指派給其中一個可用的網路介面卡。這樣會使來自相同 TCP 資料流的所有封包保留在相同的網路介面卡上。單獨雜湊通常會透過可用的網路介面卡建立平衡。市面上的部分 NIC 小組解決方案會監視流量的分佈,然後將特定的雜湊值重新指派給不同的網路介面卡,嘗試以更好的方式平衡流量。動態重新分佈也就是「智慧載入平衡」或「彈性負載平衡」

2. Hyper-v Port :

如果虛擬機器有獨立的媒體存取控制 (MAC) 位址,虛擬機器的 MAC 位址就可以提供分配流量的基礎。在虛擬化中使用這個配置有一個優點。由於相鄰的交換器可以判定特定來源 MAC 位址僅位於一個連接的網路介面卡,因此交換器將會根據虛擬機器的目的地 MAC 位址,平衡多個連結上的輸出負載 (交換器到電腦的流量)。搭配虛擬機器佇列使用時,這特別有幫助。不過,這個模式可能不夠明確,無法取得平衡良好的分佈,而且它會將單一虛擬機器限制為單一網路介面卡上可用的頻寬。

5

資料來源: http://technet.microsoft.com/zh-tw/library/hh831648.aspx

參考了Techday 2012許俊龍老師的簡報其中一頁(如下圖)

可能是我比較符合的方式,因為我的環境所有網卡接到同一台switch ,switch 設定LACP

6

設定NIC

選取網卡 > 右方 > Add to New Team

7

設定名稱以及選擇Team 以及負載平衡模式

8

設定完畢

9

11

最後設定Hyper-v 虛擬交換器

選擇[Microsoft Network Adapter Multiplexor Driver] 就是網卡小組

10

以上提供給各位參考,其中設定網卡小組模式要依照所屬環境去調整。
 

參考資料

Windows Server 2012 NIC Teaming 介绍和一些需要注意事项

Windows Server 2012 之NIC组合(NIC Teaming)介绍



本篇瀏覽人數: 2938
分類: Hyper-V篇。這篇內容的永久連結

在〈Windows Server 2012 Hyper-v NIC Team + Cisco Port-channel 設定(LCAP)〉中有 2 則留言

  1. Snack表示:

    榮哥您好,小弟最近遇到一個問題,目前我公司有一台Server的NIC用HP的軟體做Teaming,在區網連線的內容也看到是2G,但Cisco沒有設定LACP,請問這樣有增加頻寬及容錯的功用嗎?

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *